Xmanager 게시판

리모콘 사용시 Xterm은 잘 뜨는데.. Hanterm이 안뜨네요 -.-

최종입력: 2001-02-15 00:00 - ^^* | 답글: 4건

 
2001-02-15 00:00 - 밤새네ㅡ.,ㅜ

리모콘 사용시 Xterm은 잘 뜨는데.. Hanterm이 안뜨네요 -.-

 
움.. 접속하려는 서버는 MIZI Linux 1.5구요.

회사의 제 PC에서 리눅스 섭으로 Xmanager 리모콘으로 telnet 접속하면 잘 됩니다.
Xterm, Hanterm 둘 다영..
근데.. 집에서 방금 깔아서 접속하니까.. 안되는군요 ㅡ.,ㅡ

얼마 전에 방에 두루넷이 들어왔거든요.
Xmanager 써 온지 2년이 다 되어가는 듯한데..
이런 경우는 처음이네요...
하긴 유동아피로 접속해보는 것도 첨이긴 하지만요.

실행명령에
xterm -display $DISPLAY 또는 xterm -display $PCADDR:0 을 입력하면..
바로 xterm이 뜹니다.
근데 실행명령에.. xterm 대신 hanterm을 치면.. 아무 에러메시지 없이..
한텀창이 뜰 생각을 안합니다.
한참 기다려봐도 안 뜨는군요..
문제가 뭘까요 ?

회사에서 Xmanager를 사용할 때와 집에서 사용할 때의 차이라면..
다른 건 똑같고.. 설정까지 똑같이 맞췄는데...
딱 하나.. 고정아피와 유동아피라는 차이밖에는 없습니다.

혹시나 해서 $DISPLAY 대신.. 현재 할당된 Physical IP를 넣어봤는데도 역시 같은 증상이네요.

혹시 해결방법을 아시는 분은 답변 부탁드립니다 :)
이것때메.. 벌써 새벽 5시가 넘었네요 ㅡ.,ㅡ
출근 어케 하나 -.-



2001-02-15 00:00 - 지나던이

리모콘 사용시 Xterm은 잘 뜨는데.. Hanterm이 안뜨네요 -.-

 
일단 xterm이 뜬다는 것은 네트워크 상의 문제가 없다는 뜻입니다.

xterm은 뜨는데 hanterm이 뜨지 않을 경우는
hanterm이 설치되어 있지 않거나,
'실행명령'의 path가 틀렸거나,
아니면 Xmanager에 리눅스 폰트가 없는 경우일 것 같습니다.

정확한 상황을 아시려면...

'리모콘' 실행시 [진행상태 보여주기], [실행결과 보여주기]를 체크하고 실행시켜 보십시오.

그리고 나타나는 메시지를 다시 한번 게시판에 올려주시면 문제해결을 위한 방법을 알려드릴 수 있을 것 같습니다.
2001-02-15 00:00 - 밤새네ㅡ.ㅡ

리모콘 사용시 Xterm은 잘 뜨는데.. Hanterm이 안뜨네요 -.-

 
답변 남겨주셔서 먼저 감사드리구요 ^^*

hanterm이 설치되어 있지 않아서 발생한 문제는 아닙니다.
잘 깔려있거든요.. 고정아피를 가진 PC에서는 같은 설정으로 잘 뜹니다.
지금 제 회사 PC에서 잘 띄워놓고 쓰고 있거든요.

실행명령의 패쓰를 틀릴 가능성도 없습니다.
솔직히 유닉스 10년 경력을 가진 사람이 패쓰 틀린다면 쪽팔리는 얘기니까요 ㅜ.ㅜ

말씀하신 가능성 중에 리눅스 폰트가 없을 경우...
제 생각에도 이것이 문제일 것 같은 기분이 드는데요..

신기한 것은 왜 똑같은 환경의 다른 PC에서는 잘 되느냐하는 거죠 ㅜ.ㅜ
지금 사용중인 회사 PC라고 해서 새로 폰트를 추가한 것도 아닌데 말이죠.

그리고 [진행상태 보여주기], [실행결과 보여주기]를 체크하고 실행시키면..
이전 글에서도 말씀드렸다시피 아무 에러 메시지가 없습니다.

처음 로긴할 때의 로그 표시되고..

> hanterm -display 아피:0

여기까지 표시되고 가만히 있습니다.
물론 xterm을 실행할 때도 위와 똑같은 메시지가 출력됩니다만... 바로 뜨죠.

움.. 해결방법이 없다믄..
다른 솔루션을 찾아봐야겠어영 ㅡ.ㅡ
2001-02-15 00:00 - 다시 지나던이

리모콘 사용시 Xterm은 잘 뜨는데.. Hanterm이 안뜨네요 -.-

 
일단...
'실행결과창'에서 아무런 에러메시지가 나타나지 않은 것으로 보아...
연결은 제대로 된 것 같습니다.

다만..Hanterm과 Xmanager가 연결될 때,
Xmanager가 Hanterm에서 사용하는 한글 폰트를 로딩하게 됩니다.

한글 폰트는 영문 폰트에 비해 상당히 사이즈가 큰 관계로...
네트워크 트래픽이 좋지 않은 경우 시간이 많이 걸릴 수도 있죠...

연결 후 얼마정도를 기다려보는 것이 좋을 듯 합니다.
일단 폰트가 로딩되면 제 속도가 나게 됩니다.

그럼..도움이 되셨기를 바랍니다.

2001-02-15 00:00 - ^^*

감사합니다.. ^^*

 
신경 써 주셔서 감사합니다 :)