Xmanager 게시판

xmanager 접속시 다음과 같은 에레 메세지...

최종입력: 2001-04-20 00:00 - 넷사랑 | 답글: 9건

 
2001-04-18 00:00 - masamaro

xmanager 접속시 다음과 같은 에레 메세지...

 
안녕하세요...
xmanager 로 접속시 다음과 같은 에러메세지가 나옵니다.

==
설치 프로그램 /etc/X11/xdm/Xstartup 이 0(숫자) 이 아닌 상태로 종료 되었습니다.
시스템 관리자에게 문의 하시 바랍니다..
==

위와 같은 에러 메세지가 나옵니다..

OS : suse linux 7.1
리눅스 해상도 1024 * 768

FAQ 에 있는대로 했는데 안됩니다...
현재 저의 설정입니다.

***********************************************************************
!
! xdm-config: Configuration of the xdm
!
DisplayManager.errorLogFile: /var/log/xdm.errors
DisplayManager.pidFile: /var/run/xdm.pid
DisplayManager.authDir: /var/lib/xdm
DisplayManager.keyFile: /etc/X11/xdm/xdm-keys
DisplayManager.servers: /etc/X11/xdm/Xservers
DisplayManager.accessFile: /etc/X11/xdm/Xaccess
DisplayManager.willing: su nobody -c /etc/X11/xdm/Xwilling
!
! ATTENTION: `authName' should be in general MIT-MAGIC-COOKIE-1
! For XDM-AUTHENTICATION-1 which is default for xterminals see
! manual page of xdm and the manual coming with the xterminal.
!
DisplayManager.*.authName: MIT-MAGIC-COOKIE-1
DisplayManager.*.authComplain: false
!
! All displays should use authorization, but we cannot be sure
! X terminals will be configured that way, so by default
! use authorization only for local displays :0, :1, etc.
!
DisplayManager._0.authorize: true
DisplayManager._1.authorize: true
!
! The scripts handling the setup, the startup, the session its self,
! and the reset of an X session.
!
DisplayManager.*.setup: /etc/X11/xdm/Xsetup
DisplayManager.*.chooser: /etc/X11/xdm/RunChooser
DisplayManager.*.startup: /etc/X11/xdm/Xstartup
DisplayManager.*.session: /etc/X11/xdm/Xsession
DisplayManager.*.reset: /etc/X11/xdm/Xreset
!
DisplayManager._0.terminateServer: true
!
DisplayManager*resources: /etc/X11/xdm/Xresources
DisplayManager.*.terminateServer: false
!
! SECURITY: do not listen for XDMCP or Chooser requests
! Comment out this line if you want to manage X terminals with xdm
!
!DisplayManager.requestPort: 0 <- 이 부분 수정해서 리붓 했슴돠.
****************************************************************************

에러 메세지 나오는 곳을 보니
DisplayManager.*.startup: /etc/X11/xdm/Xstartup
로 되어 있습니다...
이걸
!DisplayManager.*.startup: /etc/X11/xdm/Xstartup
해서 재부팅하면 접속이 되는데 KDE 2.0 으로 접속하면 밑에 뜨는 메뉴바가
안 보입니다....
이럴때 어떻게 해야 하나요....?
좋은 하루 되세요...
2001-04-18 00:00 - 김길동

KDE 2.0 돌리기

 
저는 단일윈도우모드로 KDE 2.0 쓰고 있습니다.
2001-04-18 00:00 - masamaro

단일윈도우 모드 역시 마찬가지 입니다..

 

답변 감사합니다...
^^
2001-04-18 00:00 - 유찬석

root가 아닌 다른 계정은?

 
Xstartup에 문제가 있는 것 같네요.
root 말고 다른 계정으로 해 보시고 안되면
Xstartup 파일을 올려 주세요.
2001-04-18 00:00 - masamaro

xstartup 올립니다.

 
다른 개정은 밑에 뜨는 도구바가 안 뜹니다.
현재 xstartup 파일입니다.
************************************************************************
#!/bin/sh
#
# Xstartup: Do log on of the local or remote user by writing
# utmp/wtmp/lastlog entries for the X session.
#
# Copyright (c) 1998-2000 SuSE GmbH Nuernberg, Germany.
# please send bugfixes or comments to feedback@suse.de.
#
# Author: Werner Fink,
#
LIBDIR=/usr/X11R6/lib/X11
ETCDIR=/etc/X11
XDMDIR=${ETCDIR}/xdm
BINDIR=/usr/X11R6/bin
xmessage=${BINDIR}/xmessage
NOLOGIN=/etc/nologin

no_exit_on_failed_exec=1
type shopt &> /dev/null && shopt -s execfail
set +e &> /dev/null

#
# The real user id
#
RUID=`id -ur $USER`

#
# If login is disabled, give an appropriate message
# and exit if normal user knock on.
#
if test -r $NOLOGIN ; then
$xmessage -file $NOLOGIN -timeout 10 -default okay -center
test "$RUID" != "0" && exit 1
fi

#
# Find out if this is a local or remote connection
#
LOCATION=${DISPLAY%:*}
LINE=:${DISPLAY#*:}
if test -z "$LOCATION" ; then
# local connection
case "$LINE" in
:0|:0.0) LOCATION=console ;;
*) LOCATION=localhost ;;
esac
else
# TCP/IP connection (remote or local)
LINE=${LINE}/${LOCATION%%.*}
fi

#
# Do not allow foreign root login if set in /etc/rc.config
#
while test "$RUID" = "0" ; do
test "$LOCATION" = "console" && break
test "$LOCATION" = "localhost" && break
test "$LOCATION" = "`hostname -f`" && break
test -s /etc/rc.config && . /etc/rc.config
test "$ROOT_LOGIN_REMOTE" = "yes" && break
$xmessage -timeout 10 -default okay -center "No foreign root login allowed"
exit 1
done

#
# Make devices ready for the user.
#
case "$DISPLAY" in
:0|:0.0)
# Only for display :0 we have to set up the owner ship and
# permissions of the /dev/xconsole FIFO and the current
# virtual console /dev/tty0.

${XDMDIR}/GiveDevices
;;
*)
esac

#
# Write utmp, wtmp, and lastlog entries. Note that the `exec' is required
# to hold an exisiting pid in utmp during xsession.
#
exec ${BINDIR}/sessreg -l $LINE -h $LOCATION -a $USER
$xmessage -timeout 10 -default okay -center "$0: sessreg failed."
exit 1
****************************************************************************

입니다....

답변 감사합니다...
2001-04-18 00:00 - michael

리모트root 로그인은 금지 되어 있군요.

 
Xstartup 파일을 보니...
리모트에서 root로 로그인 하는 것이 금지 되어 있군요.
Xmanager는 리모트이니 root로 로그인을 하면 안되겠죠..

에러를 내는 부분이 다음 부분인 것처럼 보이는군요.

#
# Do not allow foreign root login if set in /etc/rc.config
#
while test "$RUID" = "0" ; do
test "$LOCATION" = "console" && break
test "$LOCATION" = "localhost" && break
test "$LOCATION" = "`hostname -f`" && break
test -s /etc/rc.config && . /etc/rc.config
test "$ROOT_LOGIN_REMOTE" = "yes" && break
$xmessage -timeout 10 -default okay -center "No foreign root login allowed"
exit 1
done

해결책은...
위의 부분을 모두 주석처리(#)하거나...
Xstartup 파일의 위쪽에 ROOT_LOGIN_REMOTE=yes라고 적어주던가..
루트가 아닌 다른 계정으로 접속하세요..


2001-04-18 00:00 - masamaro

그래도 안되는군요,,,

 
답변 감사드립니다..
그래도 안되는군요...
해상도 조절해보구,,,,해도 안되구요.,.,.
역시 밑에 뜨는 도구바는 보이지 않습니다..
처음에 부팅될때 보이다가 kde 가 100% 실행이 완료되면 하얀게 되버리는 군요..
kde 삭제하고 다시 설치할수 잇는지 궁금합니다...
어떻게 해야 하는지 알려주시기 바랍니다...
좋은 저녁 되세요...
2001-04-19 00:00 - 넷사랑

Re: 그래도 안되는군요,,,

 
KDE 2.0의 Control Panel은 Xmanager를 단일윈도우모드로 구동하면
잘 보입니다. 다중윈도우모드에서는 현재 문제가 있는데 다음 버전에서
해결될 예정입니다.
2001-04-20 00:00 - masamaro

단일 윈도우 모드도 마찬가지 입니다.

 
안녕하세요..
단일 윈도우 모드도 안됩니다...
단일 윈도우 모드로 접속하면 메뉴바가 아애 뜨지도 않습니다..
다중 윈도우 모드로 접속하면 하얗게 표시만 되구요...
좋은 하루 되세요..
2001-04-20 00:00 - 넷사랑

Suse 7.1로 테스트한 후에 알려드리겠습니다.

 
(주)넷사랑컴퓨터 기술지원팀에서 Suse 7.1로 테스트를 해보려고 합니다.
정확한 원인과 해결방법은 테스트 후에 알려드리도록 하겠습니다.

혹시 Suse 7.1을 설치한 후 KDE 설정을 바꾸셨다면 무엇을 바꾸셨는지 알려주시면 감사하겠습니다.

빠른 시간 안에 해결하도록 노력하겠습니다.
감사합니다.