Xmanager 게시판

NAT 사용시 포트매핑문제

최종입력: 2001-07-20 00:00 - michael | 답글: 3건

 
2001-07-20 00:00 - 질문자

NAT 사용시 포트매핑문제

 
훌륭한 제품입니다.
일단 로컬네트웍에서는 이상없이 돌아갑니다.
리코콘이나 x브라우저를 이용한 화면통째 가져오기....

그런데 문제는
IDC에 위치한 원격 서버입니다.
리모콘으로 개별 어플은 윈도우쪽의 x서버에 디스플레이 되나
스크린몽땅 끌어오기가 안됩니다.
실행시키면
"연결할 호스트를 찾을 수 없습니다. 다시 시도하겠습니까?"
라는 메시지가 나오면 실행결과는 아래와 같습니다.

IDC 서버의 호스트기반 방화벽은 해제하고 테스트중이며
xserver가 실행되는 네트웍은 NAT로 인터넷으로 나가게 됩니다.


xserver쪽의 포트 고정을 위해 Xserver가 살행되는 윈도우
시스템에 포트매핑을 걸어야하나요?
그렇다면 몇번 포트를 매핑시켜야 하나요
netstat로 보면 6000번이 아니고
6010 포트를 사용하는 것도 같은데요.




==================
Connected to xxx.xxx.xxx.xxx
Exchanging SSH version...Done.
Server: SSH-1.99-OpenSSH_2.3.0p1.
Client: SSH-1.5-Xssh_1.0.
SSH1 is enabled.

Authenticating remote SSH server...
Waiting for server host key...Received.
Fingerprint: 1024 20:9e:02:92:01:e5:a9:86:1f:f0:49:8b:da:ff:f6:8d.
Verifying host key...Verified.

Negotiating cipher (encryption method)...Done.
Selected cipher: 3DES.

Trying to login as root.
Trying password authentication...Done.

Requesting X11 forwarding...Done.

Requesting compression...Done.

Remote command has been requested.

X11 channel request arrived.
Establishing X11 connection (id=1)...Done.

X11 channel request arrived.
Establishing X11 connection (id=2)...Done.

X11 channel request arrived.
Establishing X11 connection (id=3)...Done.

X11 channel (id=3) has been closed.
xterm: fatal IO error 32 (Broken pipe) or KillClient on X server "xxx.xxxx.net:10.0"

Waiting for forwarded connections to terminate...
The following connections are open:
#1 X11 connection from xxx.xxxxx.net port 33002 (t4 r1 i4/0 o128/0 fd 5/5)
#2 X11 connection from xxx.xxxxx.net port 33013 (t4 r2 i1/0 o16/0 fd 9/9)
#3 X11 connection from xxx.xxxxx.net port 33014 (t4 r3 i4/0 o128/0 fd 11/11)


All forwarding channels are closed, disconnecting...

Disconnected.
2001-07-20 00:00 - michael

[Re] NAT 사용시 포트매핑문제

 
> xserver가 실행되는 네트웍은 NAT로 인터넷으로 나가게 됩니다.

이 부분이 문제입니다.
NAT를 통해 인터넷 연결을 할 때...
XDMCP는 연결하지 못할 가능성이 큽니다.

NAT 서버로 어떤 것을 사용하고 계신지요?
혹시 리눅스 마스커레이딩 서버입니까?

그렇다면 다음을 참조하세요...

/ip_masq/ip_masq1.html

2001-07-20 00:00 - 질문자

[Re] NAT 사용시 포트매핑문제

 
마스커레이딩은 아닙니다.
하드웨어적인 NAT인데요
외부로부터 내부로 들오오는 패킷중 6000포트를
찾는 패킷을 xmanger가 깔린 윈도우로 매핑시키도록 설정을
바꿨는데도 증상은 마찬가지네요.


2001-07-20 00:00 - michael

[Re] NAT 사용시 포트매핑문제

 
패킷의 내용도 수정해 주어야 합니다.
패킷의 내용에 연결해야할 X 서버의 IP 어드레스가 포함되어 있습니다.

하드웨어적인 NAT라면 아마도 XDMCP 연결은 불가능할 듯 싶습니다.

그럼...