Xmanager 게시판

XDM접속시 문제 입니다.

최종입력: 2001-07-30 00:00 - 제임스 | 답글: 2건

 
2001-07-28 00:00 - 한성호

XDM접속시 문제 입니다.

 
안녕하세요.

Xmanager나 리모콘을 실행 했을때 모두 아랴와 같은 메세지가 나옵니다.
[연결할 호스트를 찾을수 없습니다. 다시 시도하시겠습니까?]

제가 작업한 내용은 아래와 같습니다.
- /etc/inittab 파일에서 run level을 5로 설정하고,
- gdm.conf에서 [xdmcp]의 Enable의 값을 1로 설정 했습니다.
- /etc/hosts에서 Xmanager가 설치된 PC의 IP어드레스를 입력 했습니다.
- 리눅스는 redhat 7.1 버전을 현재 사용하고 있습니다.

예전에는 잘 사용을 했었는데 회사 환경이 바뀌고 나서
사용할려고 하니 이런 문제가 생깁니다.

xdm faq에서도 비슷한 문제의 증상을 찾아 문제 해결을 시도 했는데 문제가
해결되지 않습니다.
도와 주시면 고맙겠습니다.
2001-07-28 00:00 - jyory

xdm 접속 설정하기(RedHat 7.1)

 
RedHat 7.1에서는 설치 시에 보안 설정을 하실 수 있습니다.
설치 시에 가장 낮은 레벨로 설정하지 않고 설치하게 되면 기본적으로 xdm 연결을 못하도록 설정 합니다.

Xdm 접속을 허용하도록 설정을 바꾸기 위해서는
먼저 root로 로그인해서
ipchains –I input –s 0/0 –d 0/0 177 –p udp –j ACCEPT
라는 명령을 실행시키면 xdm 접속이 가능해질 거라 생각됩니다.

이 사항을 부팅할 때마다 적용시키기 위해서는
/etc/sysconfig/ipchains 라는 파일에
:input ACCEPT 라는 문장이 있습니다.
바로 그 아래에
-A input –s 0/0 –d 0/0 177 –p udp –j ACCEPT
라는 문장을 넣어 주시면 됩니다.

이상이 RedHat 7.1에서 xdm 연결을 위한 설정입니다. 물론 gdm같은 xdm daemon 이 실행되고 있어야 합니다.

리모콘 접속이 안되는 경우는 위와 같이 보안 문제로 해당 포트가 막혀 있는 경우가 있을 수 있습니다. 일반적인 telnet 터미널로 접속이 되는지 알려주세요.
2001-07-30 00:00 - 제임스

[레드헷 7.1] telnet 서비스 오픈하기

 
/etc/xinetd.d/telnet 파일을 아래와 같이 편집하세요.
그리고 xinetd 데몬 재기동.

service telnet
{
disable = no
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
}

/etc/rc.d/init.d/xinetd restart

그리고 ipchains 설정을 확인해 보세요.
tcp에 대하여 deny를 하고 있지 않는지...

/etc/sysconfig/ipchains 라는 파일에
:input ACCEPT 라는 문장이 있습니다.
바로 그 아래에 문장을 넣으신 후 ipchains를
재기동하시면 됩니다.

-A input –s 0/0 –d 0/0 23 –p tcp –j ACCEPT

/etc/rc.d/init.d/ipchains restart

--