Xmanager 게시판

KDE 화면 한 번 보고 싶어요. 제 PC에서

최종입력: 2001-10-24 00:00 - 제임스 | 답글: 13건

 
2001-10-20 00:00 - 배은덕

KDE 화면 한 번 보고 싶어요. 제 PC에서

 
저는 알짜 6.1을 쓰고 있습니다.
리모콘으로 한텀을 자주 사용하고 있습니다.
그런데 KDE 화면을 제 PC에 한 번 뿌려 볼려고 여기 있는데로 설정을 했는데
그런 내용이 없는 것도 있고 runlevel 을 5로 바꾸라는 말은 자세히 뭔지를
모르겠고 그냥 코멘트에 runlevel이라고 잠깐 언급한 곳을 5로 바꾸었구요..
DesktopManager라는 설정은 그런게 존재하지도 않아서 ! 으로 막지도 못했습니다.
그리고 재부팅을 해서 xmanager실행하니까 연결할 수 없다고 만 하네요.
그래서 X설정을 브로드캐스트랑 직접 연결을 번갈아 가면서 셋팅을 했는데도 계속
접속을 할 수 없다고 하네요
어떻게 된 건지 제가 너무 오래된 리눅스 배포판을 쓰고 있는가
나는 이게 제일 좋은 것 같은데 ...
2001-10-22 00:00 - 이은재

알짜리눅스 6.1에 XDMCP 접속 하시려면요..

 
/etc/X11/xdm/Xaccess 파일을 수정해 보세요.

# * #any host can get a login window

위와 같은 부분이 있을거에요. 맨 앞부분의 #을 제거해 보세요.
그러니까 이렇게...

* #any host can get a login window

성공하시길... 혹시 그래도 안된다면 또 질문해 주세요! :)
2001-10-22 00:00 - 배은덕

알짜리눅스 6.1에 XDMCP 접속 하시려면요..

 
그렇게는 처음에 했었어요.
혹시나 해서 다시 해 봤는데 역시나 똑같이 호스트에 연결할 수 없다고 하네요
제가 설정한 화일 내용을 보여 드리지요.


이렇게 세 개의 화일을 고쳤는데도 마찬가지의 결과가 나오군요..
어떻게 하죠.
도와주시면 좋겠는데..



첨부파일 설정파일.txt ()  
2001-10-22 00:00 - 제임스

/etc/inittab 파일을 수정하세요.

 
/etc/inittab 파일에 아래와 같은 줄이 있습니다.

id:3:initdefault:

이것을 아래와 같이 3 => 5로 변경해 주신 후 리부팅 하시면
아마도 원하는 결과를 얻을 수 있을 것 같습니다.

id:5:initdefault:

--
2001-10-22 00:00 - 배은덕

/etc/inittab 파일을 수정하세요.

 
미안합니다만, 똑같은 결과가 나오네요..
제가 windows2000 pro를 사용해서인가요..
아니면 X 설정에서 어떻게 해야하나요.
저는 직접 연결을 설정, 리눅스의 IP 번호를 적어 놓았거든요.
그리고 나서 X Manager를 실행하면 호스트를 찾을 수가 없다고 하거든요.
참 답답하기 그지 없네요.
어떻게 해야 하나요.
2001-10-22 00:00 - 제임스

네트워크는 어떻게 구성되어 있나요?

 
runlevel이 5이고 kdm과 관려한 설정(Xaccess 파일 등)을
제대로 하셨다면 ps -ax | grep dm 하시면 kdm이 동작하고
있어야 합니다. 물론 동작하고 있을것 같네요.

그렇다면 네트워크 구성은 어떻게 되어 있는지 궁금하네요.
pc와 리눅스 시스템 사이의 구성... 특히 NAT나 방화벽을
사용하지는 않는지요?

사용하고 계신 네트워크 환경을 자세히 말씀주시면 조금이라도
도움이 되는 글을 올리도록 하겠습니다.
--
2001-10-23 00:00 - 배은덕

네트워크는 어떻게 구성되어 있나요?

 
특별한 구성은 없구요.
그냥 제가 사용하는 PC의 O/S는 windows 2000 professional 이구요.
제 바로 옆에 linux pc가 있어요.
그리고
[root@SERVER /root]# ps -ax|grep dm
459 ? S 0:00 sendmail: accepting connections on port 25
548 ? S 0:00 /usr/bin/gdm -nodaemon
555 ? S 0:00 /etc/X11/X -auth /var/gdm/:0.Xauth :0
556 ? S 0:00 /usr/bin/gdm -nodaemon
562 ? S 0:00 /usr/bin/gdmlogin --disable-sound --disable-crash-d
980 ttyp0 S 0:00 grep dm

저는 지금 모니터를 연결해 놓고 있지 않습니다.
그런데, 설치시 KDE를 사용하려고 KDE셋팅을 해 놓았었고 자리를 옮기면서
모니터를 나둘 자리가 없어서 본체만 제 자리 밑에 두고 있는 실정입니다.
windows2000자체에 보안 설정이 있어서 그런지...
부탁드릴께요.
2001-10-23 00:00 - 제임스

gdm이 동작하고 있네요.

 
/etc/X11/gdm 밑에 있는 gdm.conf 파일 안의 다음 부분을
수정해 주시면 됩니다.

[xdmcp]
Enable=0 // 0 대신 1로 바꾸세요.

그리고 리부팅... 다시 연결해 보세요.
제발 해결되길... ^^;;
--

2001-10-23 00:00 - 배은덕

gdm이 동작하고 있네요.

 
됐어요...
그런데... GNOME으로 바탕화면이 나타났어요.
그래서 평소 하는것 처럼 Desktop switching tool을 사용하여 kde로
바꾸고 재부팅을 했더니 버벅되기 시작했어요.
어떻게 된거지요.
KDE를 볼려면 어떻게 해야 되나요.
다시 한번 부탁드릴께요.

2001-10-23 00:00 - 제임스

/etc/sysconfig/desktop 파일에...

 
기본 데스크탑과 xdm 데몬을 KDE와 kdm으로 변경 하시려면
/etc/sysconfig/desktop 파일을 편집기를 활용하여 다음과 같이
수정하신 후 시스템을 재기동 하세요.

DESKTOP="KDE"

GNOME으로 변경하시려면 KDE 부분에 GNOME 으로 변경하세요.
--
2001-10-23 00:00 - 배은덕

gdm이 동작하고 있네요.

 
이런 메시지를 띄우고 있어요
Sorry,your X11 Server lacks DPMS Support.
그리고는 한참 있다가 KDE화면이 뜨는데 한글이 깨어져 나오네요.
깨어져 나오는 것보다 아이콘 밑에 나와야 할 글자 자체가 각 글자당
하나의 하얀 직사각형을 형성하고 있네요.
어떻게 된 겁니다.
내가 괜히 Desktop switching tool을 손 댔는지 모르겠네요
2001-10-23 00:00 - 제임스

단일 윈도우 모드/폰트를 추가

 
먼저 X 설정에서 단일 윈도우 모드로 변경하고 연결해 보세요.
예전에 6.1에서 제공하는 KDE에 그러한 문제가 있었던 것 같습니다.
KDE를 업그레이드 하시는 것도 좋은 방법입니다.

DPMS는 Display Power Management System의 약자입니다.
리눅스 시스템에서는 유용한 것이지만 이미 Xmanager가
설치된 PC엔 MS Windows가 제공하는 DPMS가 동작하고 있습니다.
Xmanager 동작에는 영향을 미치지 않으므로 걱정하지 마세요.

그리고 리눅스 폰트는 설치하셨나요?
잘 보이지 않으면 폰트 서버나 폰트 추가 방법을 사용하셔도 됩니다.
그러한 방법에 대하여는 이 게시판을 활용하세요.
예전에 이와 유사한 질문들이 많이 올라왔으면 답글도 많이 있습니다.
--
2001-10-23 00:00 - 배은덕

단일 윈도우 모드/폰트를 추가

 
제가 Red Hat Linux 6.0 이였나?
아무튼 여러 폰트에 관련된 글들이 많이 있긴 있든데 나랑 정확하게
떨어지는 설정도 없는 것 같습니다.
저는 폰트추가는 먼저 설치 할때 부터 했고 그러면 폰트서버에
문제가 있는 것 같은데 처음 GNOME가 뜰 때는 한글이 나왔던 것
같은데 왜 이런 건지 님이 잘 알아 듣게 좀 설명 좀 해 주시면 좋겠는데요
글들이 여러개가 있으니 어떻게 봐야 할지도 모르겠고 혼란 스럽네요
멍청하지 않기 때문에 조금만 설명을 들으면 귀찮지는 않을 텐에 부탁드릴께요
그리고 포트 설정이 잘 못 될 수도 있다고 해서 포트설정을 바라는 설정 파일인데
정작 포트설정과 관련한 부분은 나오지가 않네요
7100 이 디폴트라고 하던데
좀 부탁드릴께요

#
# Default font server configuration file for Red Hat Linux 6.0
#

# allow a max of 4 clients to connect to this font server
client-limit = 4

# when a font server reaches its limit, start up a new one
clone-self = off

# alternate font servers for clients to use
#alternate-servers = foo:7101,bar:7102

# where to look for fonts
# Some of these are commented out, i.e. the TrueType and Type1
# directories in /usr/share, because they aren't forced to be
# installed alongside X.
#
catalogue = /usr/X11R6/lib/X11/fonts/misc:unscaled,
/usr/X11R6/lib/X11/fonts/75dpi:unscaled,
/usr/X11R6/lib/X11/fonts/100dpi:unscaled,
/usr/X11R6/lib/X11/fonts/misc,
/usr/X11R6/lib/X11/fonts/Type1,
/usr/X11R6/lib/X11/fonts/Speedo,
/usr/X11R6/lib/X11/fonts/75dpi,
/usr/share/fonts/default/Type1,
/usr/share/fonts/hangul/hanyang,
/usr/share/fonts/hangul/johab

# in 12 points, decipoints
default-point-size = 120

# 100 x 100 and 75 x 75
default-resolutions = 75,75,100,100

# how to log errors
use-syslog = on

# for 16-bit chars
deferglyphs = 16
2001-10-24 00:00 - 제임스

man xfs 하시면 tcp 7100 라고 나오네요.

 
먼저 예전에 되었다면 그 이후에 폰트 설정과 관련한 부분을
수정하시지 않으셨는지요?

혹시 모르니 Xmanager를 삭제 후 다시 설치하시고 리눅스 폰트를
추가해 주십시오. 한텀이 설치되어 있으면 한텀 폰트도.
레드헷 6.0이 설치된 시스템이 없는 관계로 정확한 테스트는
해 드릴 수 없네요.

그리고 폰트 서버는 xfs 라는 명령으로 수행되고 이와 관련한 정보는
man 페이지로 보세요.
거기에 포트에 대한 정보도 언급하고 있습니다.

꼭 성공하시길...
--