Xmanager 게시판

XDMCP 에러(Help~~~~)

최종입력: 2001-11-02 00:00 - 제임스 | 답글: 4건

 
2001-10-21 00:00 - 고성익

XDMCP 에러(Help~~~~)

 

지금 한컴 리눅스 2.0을 사용하고 있으며, ssh2을 사용하고 있습니다. 며칠전에 xmanager을 설치했습니다.
여기저기 정보를 찾아서 ipchain화일이랑 왠만한것 다 설정해주었는데..접속시 XDMCP에러가 발생합니다. 참고로 xmanager을 이용한 telnet접속은 되는것 같은데...

여기저기 뒤져봐도 새로운 해결책이 없는것 같아요...ㅠㅠ
2001-10-21 00:00 - 선재

Xmanager는 두가지 접근 방법을 제공합니다.

 
크게 리모콘을 이용한 접근 방법과 xdmcp를 이용한 접근을
제공하고 있습니다.

먼저 리모콘은 다양한 프로토콜(telnet, rsh, rexec, ssh)을
사용하여 원격 시스템에 접근, 원하는 X 프로그램을 실행하여
pc로 띄워주는 식으로 동작합니다.

그리고 콘솔에서 사용하는 것처럼 그래픽한 로그인 환경으로
원격지의 시스템에 접근하는 것을 xdm 연결이라고 합니다.
따라서 연결하려는 시스템에 xdm과 관련한 설정을 해야 합니다.

설정하셨던 부분과 네트워크 환경 등의 정보를 자세히 올려 주시면
성심껏 도와드리겠습니다.
2001-10-22 00:00 - 고성익

제 셋팅은 다음과 같습니다.

 
먼저 답변주셔셔 감사합니다.
저는 DSL이 win2000에 물려 있구요. 로컬로 노트북에 리눅스가 깔려 있습니다.

DSL(static ip)==>win2000(DeskTop)<==>linux(laptop)
현재 영문윈도우2000이 깔려있어서, 영문 xmanager을 사용하고 있습니다.



그리고 셋팅은 다음과 같이 했습니다. 인터넷 이곳저곳 찾아서..
===========================================================================
요사이 보안이다 방화벽이다 해서 os마다 보안관련 세팅을 해서 배포를 하더라구요.
특히 래드햇계열7.1(커널2.4.x)부터는 설치할때 아나콘다에서 사용자옵션으로 보안설정을 하는데 보통 기본 설정을 하게 되는데 이설정 때문에xmanager가 접속 에러가 나더라구요.

아래의 과정으로 세팅을 수정해보세요.
1. /etc/sysconfig/ipchains 라는 파일을 보면 아래와 같이 되어있습니다.
==================================================================
# Firewall configuration written by lokkit
# Manual customization of this file is not recommended.
# Note: ifup-post will punch the current nameservers through the
# firewall; such entries will *not* be listed here.
:input ACCEPT
:forward ACCEPT
:output ACCEPT
-A input -s 0/0 -d 0/0 25 -p tcp -y -j ACCEPT
-A input -s 0/0 -d 0/0 80 -p tcp -y -j ACCEPT
-A input -s 0/0 -d 0/0 21 -p tcp -y -j ACCEPT
-A input -s 0/0 -d 0/0 22 -p tcp -y -j ACCEPT
-A input -s 0/0 -d 0/0 23 -p tcp -y -j ACCEPT
-A input -s 0/0 67:68 -d 0/0 67:68 -p udp -i eth0 -j ACCEPT
-A input -s 0/0 67:68 -d 0/0 67:68 -p udp -i eth1 -j ACCEPT
-A input -s 0/0 -d 0/0 -i lo -j ACCEPT
-A input -p tcp -s 0/0 -d 0/0 0:1023 -y -j REJECT
-A input -p tcp -s 0/0 -d 0/0 2049 -y -j REJECT
-A input -p udp -s 0/0 -d 0/0 0:1023 -j REJECT
-A input -p udp -s 0/0 -d 0/0 2049 -j REJECT
-A input -p tcp -s 0/0 -d 0/0 6000:6009 -y -j REJECT
-A input -p tcp -s 0/0 -d 0/0 7100 -y -j REJECT
===================================================================
라고 되어있는데 자세히보면 udp포트 0에서 1023번까지 REJECT되어있습니다.
이렇게 되버리면 177번을 사용하는 XDMCP를 사용 할 수가 없습니다.
그래서 이부분을 주석처리하시고
#-A input -p udp -s 0/0 -d 0/0 0:1023 -j REJECT

또 xmanager는 포트177번으로 접속을 시도하고 응답은 6000번포트로 나갑니다
그래서 위의

-A input -p tcp -s 0/0 -d 0/0 6000:6009 -y -j REJECT

부분에서 "-A input..."부분이 reject되어있는데 xmanager가 구동하는데는 아무 상관없게죠..
물론 "-A output...REJECT" 이렇게 되어있는 경우가 있다면...xmanager가 동작하지 않겠죠..^^

하나더 xmanager에서 폰트서버를 사용하기 위해서 7100번을 사용합니다.
그래서 아래와 같이 하시면 됩니다.
#-A input -p tcp -s 0/0 -d 0/0 7100 -y -j REJECT

2.그리고 두번째
/usr/X11R6/lib/X11/fs/config 파일을 보면
==========================================================
# don't listen to TCP ports by default for security reasons
no-listen = tcp
==========================================================
이런 문장이있는데 여기서 "no-listen = tcp"을 주석 처리합니다.
그리고 나서 reboot 하시면 될겁니다.

참고로 한컴2.0은 default로 kdm이돕니다. 이 kdm은 xdm의 설정을 참조하므로
/etc/X11/xdm/ 밑에 Xaccess,xdm-config 이 두 파일을 수정하면 됩니다.
자세한 세팅은 이 게시판에 잘 나와있더라구요.
제임스님께서 올린 1331번 답변을 참조하면 되겠네요.

암튼 도움이 되었으면 하내요.



아래와 같이 linux의 파일 내용을 변경해야 Xmanager로 연결할 수 있습니다.
/etc/X11/xdm/xdm-config
DisplayManager.requestPort: 0
이 라인을 찾아 (!)로 막습니다.
!DisplayManager.requestPort: 0
/etc/X11/xdm/Xaccess
#* #any host can get a login window
이 라인의 코멘트 기호(#)를 삭제합니다.
* #any host can get a login window
위와 같이 두 개의 파일을 수정한 후 시스템을 리부팅 합니다.
b. 클라이언트 설정
A) 클라이언트인 윈도우 PC는 X설정에서 XDM접속은 직접연결로 하고, 접속하고자 하는 리눅스 PC의 IP를 적습니다.
B) 폰트 디렉토리에서 폰트 서버를 추가 하고, 리눅스 PC의 IP를 적습니다.
c. Xmanager를 실행합니다.

2001-10-22 00:00 - 고성익

참고자료

 

그리고 Xmanager을 통해 리눅스에 접속할때 다음과 같은 에러메시지가 발생합니다
==============================================================================/Connected to 192.168.0.2:22.

Exchanging SSH version...Done.
Server: SSH-2.0-3.0.1 SSH Secure Shell (non-commercial).
Client: SSH-2.0-Xssh_1.0.
SSH2 is enabled.

Negotiating algorithms...
Initiating key exchange...Done.
Exchanging Diffie-Hellman KeyEx message...Done.
Waiting for new key message...Received.
Fingerprint: 1024 31:60:c2:63:88:42:ef:9e:fd:ac:b4:14:43:22:48:ee.Verifying host key...
Algorithm negotiation has been finished...
CS Cipher: 3des-cbc, SC Cipher: 3des-cbc
CS Compress: zlib, SC Compress: zlib
CS MAC: hmac-sha1, SC MAC: hmac-sha1

Trying to login as kgenius.
Trying password authentication...Done.

Requesting session channel...Done.

Requesting X11 forwarding...Done.

Executing remote command...Done.
/usr/X11R6/bin/xauth: (stdin):1: bad display name "local:10.0" in "add"

==========================================================================
==========================================================================
2001-11-02 00:00 - 제임스

local 이라는 호스트 이름을 /etc/hosts 파일에 등록해 주세요.

 
올려주신 내용에 보면 아래와 같은 메시지가 있습니다.
여기에 있는 local이라는 이름은 리눅스 시스템의 이름이 맞는지요?
아마 그럴거라 생각됩니다.

Executing remote command...Done.
/usr/X11R6/bin/xauth: (stdin):1: bad display name "local:10.0" in "add"

이 이름을 /etc/hosts 파일에 아래와 같은 형태로 넣어주시면 됩니다.

192.168.1.1 local.domain.com local

ip 주소는 할당된 주소이고 도메인도 그쪽 환경에 맞게 넣으세요.
--