Xmanager 게시판

telnet 으로는 되는데 ssh 로는 안 되는 경우??

최종입력: 2001-10-29 00:00 - 박근영 | 답글: 1건

 
2001-10-29 00:00 - 박근영

telnet 으로는 되는데 ssh 로는 안 되는 경우??

 
안녕하세요..

Client - 10.0.0.5 (윈2000 프로페셔널, SP2 설치)
Server - 10.0.0.1 (와우리눅스7.0 까치버전, ssh2 2.4.0)

위와 같은 구성에서, Client 에서 Xmanager 로 Server 에
접속했는데, hanterm 이 뜨지 않더군요.. 영문을 몰랐는데,
접속방법을 telnet 으로 하면 잘 뜨더라고요. 그런데
SSH로 접속하려면 뜨지 않습니다.. 실행결과 메시지 창을
갈무리해보면 다음과 같습니다.

Connected to 10.0.0.1:22.

Exchanging SSH version...Done.
Server: SSH-2.0-2.4.0 SSH Secure Shell (non-commercial).
Client: SSH-2.0-Xssh_1.0.
SSH2 is enabled.

Negotiating algorithms...
Initiating key exchange...Done.
Exchanging Diffie-Hellman KeyEx message...Done.
Waiting for new key message...Received.
Fingerprint: 1024 b1:c3:76:85:82:bd:50:10:bf:d1:e4:2e:22:1d:12:6f.Verifying host key...
Algorithm negotiation has been finished...
CS Cipher: 3des-cbc, SC Cipher: 3des-cbc
CS Compress: zlib, SC Compress: zlib
CS MAC: hmac-sha1, SC MAC: hmac-sha1

Trying to login as raymundo.
Trying password authentication...Done.

Requesting session channel...Done.

Requesting X11 forwarding...Done.

Executing remote command...Done.

특별히 문제가 되는 메세지도 없어보이는데, 이유가 뭘까요?

게시판에 잠깐 살펴보니 저와 비슷하게 안 되는 경우가 있는 듯한데,
그 글타래에서도 결론이 나지 않은듯 하네요...

더 황당한 것은, 위 Client 에서 학교에 있는 컴퓨터로 접속을
시도하면 잘 된다는 겁니다. 학교에 있는 컴퓨터는 위의 Server 와
동일한 OS, 동일한 sshd 가 설치되어 있고, 심지어 sshd2_config 파일까지
완전히 동일합니다..

설마.. 10.0.0.* 을 쓰는 내부네트웍망이라서 이런 결과가 나오는 걸까요?

혹시나 해서 이번에는 학교의 컴퓨터 (공인 IP 가 부여된) 에서
집에 있는 Server 로 접속해보았습니다. (하나로 ADSL 외장형 모뎀을
경유함) 이 경우에도, ssh2 client 로는 잘 접속이 되나, Xmanager 로
접속을 하면 한텀이 뜨지 않습니다...

-display 10.0.0.5:0.0 옵션을 한텀에 강제로 주면 뜨긴 합니다. 그러나
게시판에서 찾아보니 보안이 안 된다고 하더군요.
-display $DISPLAY 옵션을 줄 경우는 처음과 마찬가지로 반응이 없습니다..

이유가 뭘까요? 학교의 컴퓨터와 집의 컴퓨터가 동일한 환경인데...
아마 제가 기억하지 못하는, 뭔가 변경된 설정이 있는 것 같은데 그게
뭘지 짐작을 못하겠네요..

그럼 안녕히 계세요~

P.S. 조*열 군은 일 잘하고 있나요? :-)
2001-10-29 00:00 - 박근영

[자답] telnet 으로는 되는데 ssh 로는 안 되는 경우??

 
Server (10.0.0.1) 의 /etc/hosts 파일에
127.0.0.1 localhost.localdomain localhost
만 적혀 있었는데, 여기에
10.0.0.1 raymundus.*.*
처럼 내부 네트웍 주소를 적어준 후에 하니까 잘 되는군요.

아무래도 공인IP 가 아닌 사설망이라서 DNS 에 없기 때문에
중간에 연결 도중에 호스트를 찾지 못했던 것 같습니다.