Xmanager 게시판

폰트서버 port:7100 활성화 시키는 방법??

최종입력: 2002-01-04 00:00 - ㅠㅠ 어렵네 | 답글: 4건

 
2001-12-05 00:00 - ihodoo

폰트서버 port:7100 활성화 시키는 방법??

 
x 매니저로 서버에 접속을 했는데 한글이 흰직사각형으로 나오는 아주 우스운 상황이 발생을 하여 알아보았더니 폰트서버를 등록해 놓으면 된다고 해서 이렇게 글을 올립니다.

X11R6 는 7100 포트를 사용한다고 합니다.
/etc/services 에 등록되어 있기에
x 설정에서 폰트서버등록을 시켰더니
사용할 수 없다는 메시지가 나오면서 텔넷 접속 자체가 안되더군요.


ping을 때려보니 돌아가질 않더군요. 핑도 들어가질 않고....
핑이 안들어가면 포트가 막혀있는 겁니까?
해결방법은요..???

2001-12-05 00:00 - Dawn_lark

폰트 디렉토리/서버 사용법

 
Xmanager사용시 한글폰트의 문제가 생길 때 '폰트디렉토리'와 '폰트 서버'를 설정해주는 방법이 있습니다.

<폰트 디렉토리 사용법>

먼저 Xmanager다운로드 컨텐츠에서 관련 폰트(linux, 한텀, 백묵)를 다운받아서 설치합니다.
그리고 x설정 => 폰트 => 폰트디렉토리추가 => xmanager 설치된 디렉토리 밑에 font라는 디렉토리에 font.dir을 찾아서 넣어줍니다.
이들 폰트들은 배포판 특성마다 linux폰트만 지정해 줘도 한글이 나오는 배포판(한컴리눅스)이 있고 한텀폰트을 설치해야 나오는 배포판(와우리눅스)이 있습니다.
저같은 경우는 한컴 2.0을 사용할때 백묵폰트로 해결 했습니다.
적용하시고 싶은 폰트를 "위로"라는 버튼으로 맨 상위로 올려놓습니다.

다시말해서 배포판마다 적절한(?) 폰트 디렉토리를 사용한다는 뜻입니다.

<폰트 서버 사용법>

다음의 파일은 아래와 같이 수정합니다.
/usr/X11R6/lib/X11/fs/config
============================================================
# don't listen to TCP ports by default for security reasons
no-listen = tcp ====> 이부분은 앞에 "#" 처리합니다.
============================================================
그런후 reboot 하세요.

그 다음 폰트 서버가 돌고 있는지 확인해봅니다.
폰트서버의 불완전한 동작이 예상될수 있으므로 아래와 같이 해서 다시 띄웁니다.
물론 root 계정에서 해야 겠죠.
/etc/init.d/xfs restart ==> 한컴인경우
/etc/rc.d/init.d/xfs restart ==> 와우, 래드해햇 경우
그리고,
#fsinfo -server 자기ip:7100
해서 제대로 정보가 나오고 있는가 확인합니다.

이제 x설정 => 폰트 => 폰트서버추가 => 리눅스호스트 ip 입력 => 적용

이렇게한 후 Xmanager를 다시 실행 해보세요.


성공여부를 알려주세요.



2001-12-05 00:00 - 최재현

폰트 디렉토리/서버 사용법

 
폰트서버 사용법 그대로 했는데요..
이러한 메시지가...

# fsinfo -server 123.123.123.12:7100
fsinfo: invalid option -- s
0)]
fsinfo: Fatal, Cannot read any input files

왜 그런거죠?
2001-12-05 00:00 - 최재현

잉??? 되네... ^^

 
어떻게 하니까 도 됩니다..

보니.. config 파일에서 주석처리 하는 부분을 하지 않았으며

또, 불안정하다는 말에 xfs 데몬을 무쟈게 restart 시켰습니다. ^^

너무 만진게 많아서리... 암튼 지금은 됩니다.

감사합니다.
2002-01-04 00:00 - ㅠㅠ 어렵네

폰트 디렉토리/서버 사용법

 
몇 번이고 그대로 따라 했는데 안됩니다.
전 와우 7.1 파란을 쓰고 있어요
게이트웨이도 같고 바로 옆에서 테스트로 하는데 Xmanager 에서 다른 아이피주소만 보이네요.. 꼭 좀 도와주세요..