Xmanager 게시판

Redhat 7.1에서 Xmanager 접속이 안되요..

최종입력: 2001-12-21 00:00 - 어제설치. | 답글: 2건

 
2001-12-20 00:00 - 어제설치..

Redhat 7.1에서 Xmanager 접속이 안되요..

 
레드햇 리눅스 7.1을 설치하고 방화벽도 설치했는데..

홈페이지에 올라온 질문들을 읽고 나름대로 따라 해봤는데 여전히 Xmanager로 접속이 안되네요.. ( 어렵네요.. 폰트서버가 어떻고.. 포트번호가 어떻고.. )

처음부터 차근차근 다시 할 수 있게 도와주세요..

먼저 무엇부터 확인하고 그 다음 뭘 수정하고... 어떻게 확인하고...

질문이 너무 광범위한건 알지만.. 답답해서 글을 올립니다..

수고하세요.

2001-12-20 00:00 - 김승환

Redhat 7.1설정법

 
먼저 Xmanager를 사용하시려면 사설ip에서 사설로 아니면 공인ip에서 공인ip 이런상태에서 가능합니다.
물론 사설에서 공인으로도 가능합니다.(방법이 다소 복잡하지만..^^)

일단 님의 상태(사설ip=>사설ip또는 공인ip=>공인ip로 가정하고)는 래드햇7.1과 방화벽을 설치한 상태이라고 하셨는데..
Xmanager을 사용하시려면 다음처럼 해보세요.

1. 리눅스 runlevel 설정

/etc/inittab 파일에서 runlevel을 5로 설정합니다.
id:5:initdefault:

2. 어떤데몬이 돌고있는지 확인후 설정.

]#ps -ef | grep dm
이라고 명령라인에 입력하시면 어떤 데몬이 동작하는지 알수 있겠죠?

gdm 환경 설정 (gdm을 사용하는 경우)

/etc/X11/gdm/gdm.conf 파일의 [xdmcp] 섹션에서 Enable의 값을 1로 설정합니다.
Enable=1


kdm 환경 설정 (kdm을 사용하는 경우)

/etc/X11/xdm/xdm-config 파일의 다음 라인을 코멘트로 막습니다.
DisplayManager.requestPort: 0 ==>
!DisplayManager.requestPort: 0

/etc/X11/xdm/Xaccess 파일의 다음 줄에 코멘트 기호(#)를 삭제합니다.
#* #any host can get a login window ==>
* #any host can get a login window

3. 방화벽을 사용하신 상태에서 설정해 주어야하는 것은

먼저 명령라인에서
]#ipchain -L -n
을 실행하시면 자신의 리눅스에 현재 설정되어있는 방화벽 상태를 볼 수 있습니다.

아래는 Xmanager를 사용하기위한 기본적인 방화벽 설정입니다.
설정하시기 정 복잡다면 이미 되어있는설정을 지우시고 아래의 내용을 입력하시면 됩니다.

================================================================
/etc/sysconfig/ipchains 파일의 앞부분에 다음 문장을 추가합니다.
-A input -p udp -s 0/0 -d 0/0 177 -j ACCEPT
-A input -p tcp -s 0/0 -d 0/0 telnet -j ACCEPT
-A input -p tcp -s 0/0 -d 0/0 ssh -j ACCEPT
-A input -p tcp -s 0/0 -d 0/0 login -j ACCEPT
-A input -p tcp -s 0/0 -d 0/0 exec -j ACCEPT
-A input -p tcp -s 0/0 -d 0/0 shell -j ACCEPT
-A input -p tcp -s 0/0 -d 0/0 7100 -j ACCEPT
================================================================
개인적으로 방화벽을 궂이 사용 할 필요가 없다면 방화벽 설정을 없애면 이 3번의 방법은 필요없겠죠..^^

이렇게 하시고 reboot 하시면 될 겁니다.

성공여부를 알려주세요.
2001-12-21 00:00 - 어제설치.

감사합니당..

 
감사합니다. 님의 설명대로 따라하니까 바로 되는데요...
뭐라 감사의 말을 전해야 할지..
암튼 잘 되니까 기분이 너무 좋네요..

추운데 감기 조심하세요~~ ^_^