Xmanager 게시판

Xbrowser을 쓰고 싶어요!!

최종입력: 2002-01-11 00:00 - 차지원 | 답글: 5건

 
2002-01-10 00:00 - 브라우져맨

Xbrowser을 쓰고 싶어요!!

 
안녕하세요
전 와우 리눅스7.0을 연결해서 쓰려고합니다
xmanager을 연결해보니 x리모콘으로 telnet,ssh도 다 되구요
그리고 xbrowser의 환경에보니까
리눅스쪽에 연결을 보니 연결이 되어있더군요
그래서 클릭을 해보니 까만 화면만 보이고 전혀 다른 화면이 나오지않고있습니다.
지금은 와우 7.0을 쓰고 있습니다
와우 7.1에서는 되었는데 외 와우 7.0에서는 되지 않고 있어요

설정을 이렇게 해주었거든요
ps -ef | grep dm 을 해보니까 전 kdm으로 되어 있더군요

종전에 무신결에 와우 7.1의 gdm인줄알고 gdm을 손을 보았죠 와우 7.1은 gdm으로 되어 있더군요
그래서 gdm을 먼저 손을 보았는데 실수였습니다
/etc/X11/gdm/gdm.conf
에서
[debug]
Enable=1

[servers]
#0=/usr/bin/X11/X
1=/usr/bin/X11/X

이렇게 설정이 했는데
다시
enable = 0
밑에 모두다 #으로 막아 두었습니다

그리고 kdm을 설정하려고 보니까

여기 설명서에 적혀 잇는 몇가지 화일이 보이지 않더군요

첫번째가 /etc/X11/xdm/xdm-config 이 파일이더군요
아무리 찾아보아도 없더군요 어디 있는것이죠???
find 명령으로 찾아 보아도 없고?? 어디로도망간것인지??

두번째는
/etc/X11/xdm/kdmrc 혹은 /usr/share/kdm/kdmrc
이화일을 찾아 보니까(find) 어뚱한곳있더군요
/usr/share/config/kdmrc에 있더군요
그런데 문제는 여기 이화일에서 수정하라는 부분
Enable=true <-----이부분을 아무리 찾아 보아도 없더군요

홍알 홍알 거립니다..

딱 한개 화일만 있더군요
/etc/X11/xdm/Xaccess
이것을 설명서대로 해주었습니다..

문제는 xmanager에 보라색에 아이콘을 처음에 클릭하면 전혀 안된다는 사실이고요
두번째는 Xbrowser에 아이콘은 들어 가보면 링크는 되어 있는데
화면은 전혀 아무것도 안나온다는 점이구요
세번째는 이 kdm설정화일 두개는 어디서 찾죠??
네번째는 kdm 데몬을 죽이고 gdm데몬을 설정하고 싶은데요
패키지를 어떤것을 다시 깔아야죠???
kdm데몬은 어떻게 죽이죠??
kill로 해서 죽일수는 있지만 부팅할때마다 다시 뜨면 안되니까 혹시 다른 방법좀
알려주세요~~

혹시 설정해보신분이나 자세히 아시는 운영자님 좀가르쳐 주세요!!네
와우 7.0으로 모든것을 자세히 세팅해주었기때문에
지울수도 없어요~~힝힝
2002-01-11 00:00 - 차지원

[답변]이렇게 해보세요. <== 수정본

 
님께서 말씀하신 설정가운데 몇가지 잘 못된 설정이있어요.

설정에 들어가기에 앞서 넷사랑에서 공지한 설정부분은 모든 배포판마다 동일하게 적용되는게 아니라
RedHet 계열을기준으로 한것 같습니다. 그래서 와우나 한컴또는 수세...등과는 약간의 파일위치라든가
파일의 존재유무를 확인할 필요가 있습니다.

첫째,
/etc/X11/gdm/gdm.conf
맨 아래를 보면 님께선 둘다를 "#"로 막아 두셨다고 했는데.. 그러면 콘솔에서 Xwindow환경
을 볼수없습니다.
[servers]
#0=/usr/bin/X11/X
#1=/usr/bin/X11/X

[servers]
0=/usr/bin/X11/X <== 이렇게 바꾸세요.
#1=/usr/bin/X11/X

두번째, kde는 xdm과 동일한 데몬을 사용합니다.
/etc/X11/xdm/xdm-config 은 배포판마다 있는 것도 있고 없는 배판도 있더라구요.
와우7.0에서는 없습니다.
그래서 설정을 안하셔도 되고.

세번째,
/etc/X11/xdm/Xaccess
이것은 설명서대로 해주었다고 하니 이상없겠구요..
그리고 나서 reboot 해보세요.

네번째,
/etc/X11/xdm/kdmrc 혹은 /usr/share/kdm/kdmrc는 래드햇 7.1의 위치한 파일이더군요.
위에 언급했듯이 파일위치가 다를 수있습니다.
저도 찾아보니 님께서 말씀하신 /usr/share/config/kdmrc에 있더군요
그리고 설정을 보니 별다른 설정을 안하셔도 됩니다.
kdmrc 설정은 kde2.x.x버젼부터 설정되는 파일내용입니다.
와우7.0은 kde1.1.x버젼이기에 영향을 미치지 않습니다.
참고로 래드햇7.2는 /etc/kde/kdm/kdmrc아래에 있습니다.


다섯째,
==================================================================
kdm 데몬을 죽이고 gdm데몬을 설정하고 싶은데요
패키지를 어떤 것을 다시 깔아야죠???
kdm데몬은 어떻게 죽이죠??
kill로 해서 죽일수는 있지만 부팅할때마다 다시 뜨면 안되니까 혹시 다른 방법좀
알려주세요~~
=================================================================
이 부분은 님께서 처음 와우를 설치하실때... kde와 gnome를 둘다 설치하셨는지
아니면 kde만 설치하셨는지 여부에 따라 다를 수있습니다.(패키지 설정하는 부분에서)
만약 패키지 설치하는 부분에서 설정을 안하셨다면 처음 부팅하셨던 것처럼 cd를 넣고
"upgrade설치" 부분을 하셔서 gnome를 설치해보세요.

꼭~~ 성공하세요...^^
2002-01-11 00:00 - 브라우져맨

[답변]이렇게 해보세요.

 
감사합니다..
님이 말씀하신데로 해보았는데요
안되는데요
xbrowser에서는 링크는 걸려있는데
클릭을 하면은 화면은 뜨는데요 로그인 화면은 뜨지 않고 있고요
연결호스틀 찾을수 없다고 나옵니다..
외 안될까요
이제 cd업그레이드를 해보는 수밖에 없는것 같군요
허허 외 안될까요??
그럼
2002-01-11 00:00 - 차지원

죄송 다시 설정..

 
첫째, 부분에서 아래와 같이 하시라고 했는데
--------------------------------------------------------------
/etc/X11/gdm/gdm.conf
에서
[xdmcp]
Enable=1
--------------------------------------------------------------
님께서 default가 kdm(kde데몬)라는 것을 깜박하고 답변을 잘 못드렸습니다.

kde는 xdm을 사용하므오 gdm의설정을 안하셔도 됩니다.
그래서 원래대로 설정을 해두시면 됩니다.

-------------------------------------------------
/etc/X11/gdm/gdm.conf
에서
[xdmcp]
Enable=0 <=="1"을 원래대로 "0"으로 해두세요
------------------------------------------------

/etc/inittab 에서 설정하는 부분을 "5"로 물론 해두셨겠죠..?
=======================
id:5:initdefault:
=======================

그리고 reboot 해보세요.

그래도 안되신다면,

님께서 설정하신 부분을 자세히 올려주세요...
/etc/X11/xdm/Xaccess 설정, /etc/X11/gdm/gdm.conf설정, /etc/inittab 설정
그리고 다른 pc에서도 접속이 안되는지.. 궁금하네요.

답변기다립니다.


2002-01-11 00:00 - 브라우져맨

죄송 다시 설정..

 
감사합니다 그런데 그방법도 안좋더군요
안되어요
그냥 저에 원인을 찾다가 해결방법을 제시합니다.
그냥 님이 말씀하신 설정으로
하면 kdm은 죽어도 안될겁니다
외 안되는지 이유는 저도 차차 해보기로 하겠지만요
업그레드 다 해보았는데

가장 좋은 방법은 kdm -->gdm을 바꾸는 방법밖에 없더군요
님이말씀 하신 방법으로 좋은 방법이구요

저같은 경우에 있는 분은 이렇게하면 되더군요
/etc/X11/prefdm 이라는 화일이 kdm과 gdm을 설정 장확하고 있더군요
외 이 화일이 두 모듈을 장확하는지 한번 보니
/etc/inittab에 제일 밑에 보니까 이 prefdm으로 xdm을 설정을 해두었더군요

그래서 prefdm의 화일을 vi편집기로 보시면 아시겠지만
if문으로 제어를 해두었두었더군요
제가 가장 알고 싶었던 데몬을 살리고 죽이는 것 이더군요
거기 제어문을 보면 바로 이렇게 되어있죠
/etc/sysconfig/desktop에 GNOME을 설정시 -->gdm
그렇지 않고 KDE이면 kdm이라고 되어 있더군요
##결론을 다른것 할필요없이 /etc/sysconfig/desktop에 KDE을 삭제하고
GNOME을 해주고 재부팅하니까
kdm은 없고 gdm을 짜짠 세팅이 되었습니다...

그리고 나머지 gdm세팅해주는것 처럼 해주니까
와우 한글도 보이넹!!!ㅋㅋㅋㅋ 한글도 안깨지고 와우~~
잘보이네요~~

여하튼 님 께서 수고 해주신것 감사드립니다..
저도 시간나는데로 kdm 에러 원인을 한번 찾아보죠~~
그럼
2002-01-11 00:00 - 차지원

글쎄 문제가 뭘까요?

 
님께서 처음 와우를 설치할때 gnome도 추가하셨다면 님께서 말씀하신대로
/etc/sysconfig/desktop 에서"GNOME" 하시면 됩니다.

저도 개인적으로 와우 7.0을 사용하는데...
방금 님께서 말씀하신대로의 설정이 정말 안될까 궁금해서

/etc/sysconfig/desktop 에서"KDE"로 바꾸고 XMANAGER를 실행시켜보니
KDE WINDOW환경이 잘 보입니다.

글쎄요....
님께서 설정하신 부분이 말씀드린대로의 설정이 정확하다면 저도 궁금해지네요..^^

암튼 kde 환경에서도 성공하시길~~