Xmanager 게시판

SSH 설치중 오류...

최종입력: 2002-08-08 00:00 - 강성광 | 답글: 1건

 
2002-08-08 00:00 - 나그네

SSH 설치중 오류...

 
사설 ip에서 공인ip 서버로의 Xmanager 연결을 위해
ssh를 설치하려던중 오류가 났습니다
일전에 오류가 났을때 openssl을 설치하라고 하셔서 설치하고
openssh를 설치하려는데, config하고 make를 하는데
아래와 같은 오류가 나옵니다...


gcc -o ssh ssh.o sshconnect.o sshconnect1.o sshconnect2.o sshtty.o readconf.o clientloop.o -L. -Lopenbsd-compat/ -L/usr/local/ssl/lib -R/uso
정의되지 않음 첫번째 참조된
기호 파일의
dlclose /usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o) (암시적 의존성 /usr/lib/libdl.so.1에 속한 기호)
dlsym /usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o) (암시적 의존성 /usr/lib/libdl.so.1에 속한 기호)
dlopen /usr/local/ssl/lib/libcrypto.a(dso_dlfcn.o) (암시적 의존성 /usr/lib/libdl.so.1에 속한 기호)
ld: 치명적: 기호 참조 오류. ssh에 출력이 기록되지 않음
collect2: ld returned 1 exit status
make: *** [ssh] Error 1

어떤것땜에 그럴런지 답변부탁드립니다.
2002-08-08 00:00 - 강성광

RE : SSH와 SSL의 버전을 확인해 주세요.

 
설치중 발생할 수 있는 문제는 설치파일에서 요구하는
의존성에 문제가 있을 때 발생할 수 있습니다.

OpenSSH의 INSTALL 문서나 README 문서를 보시면
설치하는데 필요한 요구사항이 기록되어 있습니다.
OpenSSH의 버전에 따라 필요한 OpenSSL의 버전이 다르기
때문에 요구사항에 맞는 OpenSSL을 설치하여 주셔야 합니다.
또한 필요한 요구 사항을 모두 만족하고 있는지 확인을
하신 이후에 설치하셔야 합니다.

OpenSSH와 OpenSSL의 버전을 확인 하신 이후에
필요한 버전의 OpenSSL을 설치하시고 그 이후에 OpenSSH를
설치하시면 될거라 생각됩니다.

그럼 이만