Xmanager 게시판

레드햇9 에서 eclipse 실행 에러

최종입력: 2003-09-19 14:53 - 넷사랑 | 답글: 1건

 
2003-09-19 13:55 - 최운용

레드햇9 에서 eclipse 실행 에러

 
eclipse에 관련 에러에 대한 질문을 올린 것을 찾아서 읽어 보았습니다. 그런데 제가 겪고 있는 문제 현상과 달라서 이렇게 메일을 올립니다.

우선 제가 실행하는 환경은 다음과 같습니다.

server: redhat9
client: window xp home
xmanager: 1.3.9

이 상태에서 eclipse를 서버에서 직접 실행하면 정상 작동을 하지만 xmanager를 통해서 실행을 시키면 실행 자체가 되지를 않군요. eclipse는 gtk 버젼이구요.

에러 메시지는 첨부 파일로 첨부합니다. 검토 하시고 답신 부탁드립니다.
첨부파일 1.jpg (53.1 KB)  
2003-09-19 14:53 - 넷사랑

Re: 레드햇9 에서 eclipse 실행 에러

 
안녕하세요? (주)넷사랑컴퓨터입니다.

말씀하신 문제는 eclipse(gtk)가 필요로 하는 color depth 때문에 발생합니다. 다음 차례대로 eclipse를 실행하시기 바랍니다.

1. X설정에서 다음과 같이 옵션을 바꿉니다.
- 컬러 > Default Visual > PseudoColor
- 옵션 > Backing Store > When Mapped

2. elipse 실행시 사용자의 workspace를 따로 지정하여 사용합니다.
예) $ eclipse -data ~/.eclipse.xmgr -vm /usr/java/j2sdk1.4.2_01/jre/bin/java

3. Locale을 C나 en_US로 하시면 Redhat 8 이상 버전에서 Pseudo color로 eclipse 사용시 다소 나은 화면을 얻으실 수 있습니다.

4. 사용자 환경에 변화가 있으면 말씀하신 문제가 발생합니다. 이때에는 다음 경로에 있는 platform 정보파일을 삭제하고 eclipse를 재시작합니다.

~/.eclipse.xmgr/.metadata/.config/platform.cfg


참고로 motif 버전의 eclipse의 경우 위와 같은 문제가 발생하지 않으며, 위 사항들은 Xmanager 차기 버전에서 개선될 예정에 있습니다.

감사합니다.

(주)넷사랑컴퓨터