Xmanager 게시판

Xmanager 접속이 안되서요.. (fedora core1)

최종입력: 2004-08-29 12:44 - 김연희 | 답글: 4건

 
2004-08-27 13:36 - 김연희

Xmanager 접속이 안되서요.. (fedora core1)

 
안녕하세요?
저는, Fedora core 1을 사용하고 있는데요..
xdm-faq에 나와있는데로, 다 설정을 해줫거든요.
그런데, 연결이 안되요.
[security]에서 수정하면, 아예 "폰트서버"를 못찾는다고 나오구요..
수정하지 않으면.. 실행하고 로그인화면까지 뜨거든요.
로그인 하고 나서 조금 있다가 창이 닫혀버려요..

다음은.. Xmanager 로그파일입니다.^^;
------------------------------------------------
.....
Local Hostname: '김연희'
Local Host IP Address: 10.1.22.180
Screen Resolution: 1024 x 768
Size of Palette: 0
Number of Reserved Colors: 20
Resolution of Color: 24
Depth of Screen: 32
Maximum Cursor Width: 32
Maximum Cursor Height: 32
Maximum Client Area Width: 1024
Maximum Client Area Height:712
Width of Display(mm): 270
Height of Display(mm): 203
Dots Per Inch X: 96
Dots Per Inch Y: 96
Icon Width: 32
Icon Height: 32
Caption Height: 26
DBCS Enabled: 1
GDI batch limit: 20
Mouse buttons: 2
Screen 0: 1024 x 768
=== OS Version Information ===
Platform id : 2
Major Version : 5
Minor Version : 1
Build Number : 2600
Description : "Service Pack 1"
Country Code : 82
Country String: 대한민국
==============================
WSAAyncSelect() on fd 6 failed, event: 33
Error: fd 6 not openned in ../../.././lib/xtrans\Xtranswinsock.c, 321
XdmcpFill: too few bytes(-1) received
SocketINETAccept: accept() failed, errno: 10035
X server was terminated normally.
2004-08-27 14:23 - 넷사랑

Re: Xmanager 접속이 안되서요.. (fedora core1)

 
안녕하세요? 넷사랑컴퓨터입니다.

Fedora의 경우 /etc/X11/gdm/gdm.conf 파일의 [security] 섹션에서 DisallowTCP의 값을 false로 설정해야 합니다.

폰트 서버를 사용할 때 설정은 FAQ 10번을 참고하십시오.

/products/xmg_faq.html

로그인 후 창이 닫히는 것은 DISPLAY 설정이나 퍼미션 설정 문제라 생각됩니다.

.bashrc 등의 시작 스크립트에서 DISPLAY 변수가 강제로 설정되어 있으면 이 부분을 주석처리하시고, 사용자 홈디렉토리에 충분한 권한이 있는지 확인하십시오.

감사합니다.
2004-08-27 14:41 - 김연희

Re: Re: Xmanager 접속이 안되서요.. (fedora core1)

 
설정한 값들은..
/etc/X11/xdm/xdm-config
==>!DisplayManager.requestPort:0 (이거 해야되나요? kdm사용할 때만 설정하는건가요??)

/etc/X11/gdm/gdm.conf
==>
[xdmcp]
Enable=true

/usr/X11R6/lib/X11/fs/config
==>#no-listen

아, 그리고, /etc/sysconfig/iptables에서
-A INPUT -p tcp --dport 7100 -j ACCEPT 이거 추가해준다음에요..
/etc/init.d/iptables restart했거든요..

[security] 부분을 설정하면, 아예 gdm이 안뜨는데요..
폰트 서버를 찾을 수 없다고 나옵니다..

폰트 서버는 추가해놨거든요..

그리고, 권한 설정이랑 다 되더있는데요..
.bashrc에는 DISPLAY 설정 따로 안했는데요.. ㅡ.ㅡa

어떻게 해야되죠? ^^;
2004-08-28 01:58 - 넷사랑

Re: Re: Re: Xmanager 접속이 안되서요.. (fedora core1)

 
안녕하세요? 넷사랑컴퓨터입니다.

문제 상황을 정리해보도록 하겠습니다.

1. gdm.conf의 [security] 부분에서 DisallowTCP의 값을 false로 하면 폰트 서버를 찾을 수 없다는 메시지와 함께 gdm이 구동이 되지 않고, true로 하면 로그인 창은 잘 넘어가고, 그 후 최종 화면이 뜨지 않는 상황이라고 하셨습니다.

Fedora의 경우는 위의 DisallowTCP의 값이 false로 설정 되어야 Xmanager 사용이 가능한 것으로 알고 있으며 이 값은 false로 맞추고 다른 원인을 찾아보아할 것입니다.

2. 폰트 서버의 설정을 바꾼 후에 폰트 서버를 재구동 하셨는지도 확인해 보십시오.

3. iptables 방화벽 설정도 문법에 맞는지 다시 한 번 확인해 보시고, 문제 원인 파악을 위해 아래와 같은 명령어로 잠시 방화벽을 꺼보십시오.

# service iptables stop

4. 폰트 서버 관련 문제일 수 있으므로, Xconfig에서 폰트 서버를 제거한 후 Xmanager를 재구동 해 보시기 바랍니다.

5. .bashrc 외에도 .cshrc, .profile 등 그 계정이 사용하는 로그인 스크립트는 모두 다 살펴보셔야 합니다.


저희도 자체적으로 Fedora Core 1 을 설치해서 테스트를 진행하도록 하겠습니다.

감사합니다.
2004-08-29 12:44 - 김연희

Re: Xmanager 접속이 안되서요.. (fedora core1)

 
말씀하신대로 다 확인해봤는데..
똑같습니다.. ^^;

페도라 코어 1 설치하셔서 테스트되시면.. 답변 부탁드리겠습니다~ 꾸벅..(^^)(__)(^^)