Xmanager 게시판

서버에 연결은 되는데 x-terminal 실행이 안됩니다.

최종입력: 2004-10-27 16:42 - 넷사랑 | 답글: 3건

 
2004-10-27 13:59 - 이승철

서버에 연결은 되는데 x-terminal 실행이 안됩니다.

 
서버에 연결은 되는데 termianl 실행이 안됩니다.
명령어가 실행안되는건지 이유를 모르겠습니다.

(C) Copyrights by IBM and by others 1982, 1996.
login: root
root's Password:
*******************************************************************************
* *
* *
* Welcome to AIX Version 4.3! *
* *
* *
* Please see the README file in /usr/lpp/bos for information pertinent to *
* this release of the AIX Operating System. *
* *
* *
*******************************************************************************

------------------------------------------------------
!!! Warning !!!

시스템에 불법적으로 접근할 경우 민형사상 고발 조치 함!
------------------------------------------------------

Last unsuccessful login: Tue Oct 26 18:17:39 2004 on /dev/pts/3 from pc17n36.icols.com
Last login: Wed Oct 27 13:57:01 2004 on /dev/pts/12 from pc22n129.icols.com

WAS[/]

이 상태에서 커서만 깜빡이고 아무것도 실행이 되지 않습니다.
이유를 못찾겠습니다
도와주세요
2004-10-27 14:24 - 넷사랑

Re: 서버에 연결은 되는데 x-terminal 실행이 안됩니다.

 
안녕하세요? 넷사랑컴퓨터입니다.

보내주신 정보를 살펴보니 일반적으로 사용하지 않는 프롬프트 형태(WAS[/])가 나타나서 Xstart가 프롬프트임을 인식하지 못한 상황이라 생각됩니다.

Xmanager2 의 경우 다음 2가지 방법으로 해결할 수 있습니다.

1. Xstart를 열고 고급 옵션을 선택
2. 프롬프트 탭을 클릭
3a-1. "다음 문자열이 발견되면 쉘 프롬프트로 인식" 선택
3a-2. 문자열에 다음과 같이 [/] 추가 (공란이 포함되지 않도록 주의하십시오)
예: $|%|>|#|}|[/]

혹은,

3b-1. "다음 시간 동안 기다린 후 쉘 프롬프트가 나타난 것으로 인식" 선택
3b-2. 대기 시간에 적절한 시간 입력

문제가 해결되지 않으면 아래 정보를 보내주십시오.

1. Xmanager 버전
2. 사용한 프로토콜의 종류
3. root 가 아닌 다른 계정의 접속 가능 여부

감사합니다.
2004-10-27 15:08 - 이승철

감사합니다만..그런데..아직도 아무런 반응이없네요...ㅠ.ㅠ

 
1. Xmanager 버전:2.0
2. 사용한 프로토콜의 종류: telnet
3. root 가 아닌 다른 계정의 접속 가능 여부:
"wasuser"로 접속이 가능합니다.



AIX Version 4

(C) Copyrights by IBM and by others 1982, 1996.

login: root
root's Password:
*******************************************************************************
* *
* *
* Welcome to AIX Version 4.3! *
* *
* *
* Please see the README file in /usr/lpp/bos for information pertinent to *
* this release of the AIX Operating System. *
* *
* *
*******************************************************************************

------------------------------------------------------
!!! Warning !!!

시스템에 불법적으로 접근할 경우 민형사상 고발 조치 함!
------------------------------------------------------

Last unsuccessful login: Tue Oct 26 18:17:39 2004 on /dev/pts/3 from pc17n36.icols.com
Last login: Wed Oct 27 15:05:57 2004 on /dev/pts/12 from pc22n129.icols.com

WAS[/]/usr/bin/X11/xterm -ls -display 191.2.XX.XXX:0

이 상태에서 아무런 반응이 없습니다.
도움 부탁드립니다.
2004-10-27 16:42 - 넷사랑

Re: 감사합니다만..그런데..아직도 아무런 반응이없네요...ㅠ.ㅠ

 
안녕하세요? 넷사랑컴퓨터입니다.

root가 아닌 wasuser로는 Xstart 접속이 가능한 상황이라면, 보내주신 로그의 마지막에 있는 display(191.2.XX.XXX)가 PC의 IP와 다를 수 있습니다.

위와 같은 경우에는 $HOME 디렉토리에 있는 .cshrc, .login 등의 스타트업 스크립트에서 DISPLAY 강제 설정 부분을 모두 제거해야 합니다.

또한 "WAS[/]"라는 문자열이 해당 서버의 쉘 프롬프트가 맞는지 확인해보아야 합니다. Xstart가 아닌 일반 telnet 클라이언트로 확인해볼 수 있습니다.

다음과 같은 추가 정보를 보내주시면 문제해결에 도움이 될 것입니다.

1. 일반 telnet 클라이언트로 root 접속 시 쉘 프롬프트 문자열
2. Xstart를 이용하여 wasuser로 접속 했을 때 원격 실행 결과창 내용 전부
3. 보내주신 로그 마지막 부분의 IP(191.2.XX.XXX)가 Xmanager가 설치된 PC의 IP와 동일한지의 여부
4. 서버와 PC의 네트워크 구성 상황

감사합니다.