Xmanager 게시판

xsession indirect 를 이용한 연결이 안됩니다.

최종입력: 2007-10-26 10:43 - 최소영 | 답글: 13건

 
2007-10-23 16:43 - 최소영

xsession indirect 를 이용한 연결이 안됩니다.

 
안녕하세요.

서버는 페도라6 환경인데요. 서버는 xbroswer에서 안잡혀서 indirect를 이용하여 연결하려고 했는데 안됩니다.
서버에 x윈도우로 연결하고 싶은데 무슨 방법이 없을까요..
아래는 캡쳐한 화면입니다.
2007-10-23 17:49 - 넷사랑

Re: xsession indirect 를 이용한 연결이 안됩니다.

 
안녕하세요. 넷사랑컴퓨터 기술지원입니다.

Xbrowser를 이용한 XDMCP 접속을 하기 위해서는 다음의 조건이 만족되어야 합니다.

1. PC에서 리눅스 장비로 UDP 177번 통신이 가능할 것
2. 리눅스 장비에서 PC로 TCP 6000~6010번 통신이 가능할 것
3. 리눅스 장비에서 디스플레이 매니저가 구동되고 XDMCP 서비스가 활성화되어 있을 것

밑의 답변에서도 말씀드렸지만, 저희 FAQ에 XDMCP 접속을 위한 설정 방법이 자세하게 설명되어 있으니 다음 페이지의 Step 3을 참조해보시기 바랍니다.

/download/down_xmg2.html

설정하다가 궁금하신 사항이 있으면 언제든지 문의해주시면 자세하게 답변해 드리겠습니다.

감사합니다.
2007-10-24 13:47 - 최소영

Re: Re: xsession indirect 를 이용한 연결이 안됩니다.

 
말씀하신대로

1.XDM설정

- Linux Level설정 : /etc/inittab파일의 runlevel을 5로 설정
id:5:initdefault:

- gdm환경설정 : /etc/gdm/custom.conf 의
[xdmcp] Enable=1
[security] DisallowTCP=false


2. 방화벽

- PC UDP 177포트개방
- Fedora 6 방화벽의 TCP 6000~6010개방

그런데도 Xbrowser를 이용해서 페도라서버에 접근하려고 하면 위와 같은 메시지 연결할수 없다는 메시지 박스가 나옵니다.

아래 설정했던 화면 캡쳐한 것입니다.

에러화면은 위에 올린것과 동일 합니다.

아래 로그파일 첨부합니다.
2007-10-24 14:23 - 넷사랑

Re: Re: Re: xsession indirect 를 이용한 연결이 안됩니다.

 
안녕하세요. 넷사랑컴퓨터 기술지원입니다.

Xmanager를 사용하기 위해서는 리눅스 장비의 UDP 177번 포트, PC의 TCP 6000~6010번 포트를 개방하셔야 합니다. 현재 설정이 반대로 되어 있으니, 다시 설정하고 접속을 시도해보시기 바랍니다.

위의 방법으로 문제가 해결되지 않는다면, Xmanager 로그 파일을 보내주시면 문제의 원인을 파악하는데 도움이 될 것 같습니다.

감사합니다.



2007-10-24 16:07 - 최소영

Re: Re: Re: Re: xsession indirect 를 이용한 연결이 안됩니다.

 
올려주신 답글대로 리눅스 UDP 177 오픈하고 PC 6000~6010 오픈했는데도 연결안됩니다.

요청하신 로그파일을 올립니다.
첨부파일 Log.zip (7.5 KB)  
2007-10-24 17:23 - 넷사랑

Re: Re: Re: Re: Re: xsession indirect 를 이용한 연결이 안됩니다.

 
안녕하세요. 넷사랑컴퓨터 기술지원입니다.

전에도 말씀드렸다시피 Xmanager를 사용하려면 다음의 조건을 만족하면 됩니다.

1. PC에서 리눅스로 UDP 177번 통신 가능
2. 리눅스에서 PC로 TCP 6000~6010번 통신 가능
3. 리눅스 장비에서 XDMCP 서비스가 활성화되고 디스플레이 매니저가 구동될 것

보내주신 로그 파일의 내용을 보면 디스플레이 매니저가 구동되고 있지 않은 것 같습니다. 시스템을 재부팅하거나 init 3; init 5 명령을 실행하셔서 디스플레이 매니저를 구동한 후 접속을 시도해보시기 바랍니다.

ps –aef | grep dm 명령을 내리면 현재 사용하고 있는 디스플레이 매니저를 알 수 있으니, 혹시 gdm 외의 디스플레이 매니저를 사용하고 있다면 해당 디스플레이 매니저에 맞는 설정을 한 후 접속하시면 됩니다.

기타 궁금한 사항이 있으면 언제든지 문의해주시기 바랍니다.

감사합니다.
2007-10-24 18:20 - 최소영

답변을 주십시요...답변을 기다리고 있습니다.

 
안녕하세요. 답글 감사드립니다.

PC쪽 TCP 6000~6010, 리눅스쪽 UDP 177포트는 열어놓았습니다.

디스플레이매니저는 gdm인것 같은데요...

init 3; init 5 로 시스템 재시작 몇 번 했구요..

그리고 gdm 설정 부분

/etc/gdm/custom.conf 의

[xdmcp] Enable=1
[security] DisallowTCP=false

했습니다.

ps -adf | grep dm 을 하면 디스플레이매니저의 종류를 알게된다고 하셨는데 해보니까... gdm 인것 같으네요

gdm을 구동하는 것이 단지 init 3; init 5 로 시스템 재시작만 하면 되는 것인지 아니면 다른 방법이 있는지 궁금합니다.

설정 다 해주고 시스템 재시작 여러번 했구요.. 그 후 연결시도 몇 번 했지만 다 실패했거든요


다시 질문합니다.

gdm을 구동하는 방법 즉 디스플레이매니저를 구동하는 방법은 무엇인가요?

아래 ps -adf | grep dm의 결과를 첨부합니다.
첨부파일 gdm.JPG (116.4 KB)  
2007-10-25 13:43 - 최소영

gdm restart, gdm start를 하고 연결시도 해도 안되네요

 
디스플레이 매니저가 구동이 안되는 거라면...
디스플레이 매니저를 구동할 수 있는 방법을 문의드립니다.

gdm restart, gdm start, init 3, init 5 모두 다 해보고 연결시도해도 안되거든요...

다른 방법이 있으면 좀 알려주세요.
2007-10-25 14:01 - 넷사랑

Re: gdm restart, gdm start를 하고 연결시도 해도 안되네요

 
안녕하세요. 넷사랑컴퓨터 기술지원입니다.

보내주신 스크린 샷을 보니 gdm이 정상적으로 구동되고 있습니다. 디스플레이 매니저는 gdm, kdm 등과 같은 명령어 입력으로 구동이 가능합니다. init 명령이나 시스템 재부팅을 하라고 하는 것은 변경된 설정 사항들을 적용시키기 위함입니다.

최근의 리눅스에는 selinux라는 강화된 보안 정책 기능이 있습니다. Fedora Core 6에도 selinux가 있는데, 여기서 접근 제어가 이루어져서 gdm으로의 접속을 방해하고 있을 수도 있으니 이 기능을 disable 시키고 접속해보시기 바랍니다. /etc/sysconfig/selinux 파일에서 SELINUX 항목을 disabled로 설정하거나, 콘솔의 그래픽 환경에서 시스템 -> 관리 -> 보안 수준 및 방화벽에서 설정한 후 시스템을 재부팅하십시오. 방화벽 설정에서도 문제가 있을 수 있으니 방화벽도 사용하지 않는 상태에서 접속해보실 것을 권해드립니다.

위의 방법으로도 문제가 해결되지 않는다면, 사용하는 PC에서 리눅스 장비까지 UDP 177번 통신이 정상적으로 이루어지는지 점검해 볼 필요가 있을 것 같습니다. 패킷 손실 등이 발생할 수도 있으니 네트워크 담당자에게 문의하셔서 그 부분을 확인해보시기 바랍니다.

감사합니다.
2007-10-25 15:26 - 최소영

SELINUX disable 되어 있는데요..

 
답변 감사드립니다.
말씀하신 /etc/sysconfig/selinux 의 SELINUX 는 disable되어 있네요...


네트워크 문제일 수도 있겠다는 말씀을 하셔서 네트워크 설정에 혹시 문제가 있나 싶어서 네트워크 설정을 캡쳐해서 올립니다.

수고스러우시지만 한 번 봐주세요.

그리고 또 하나 Xbrowser 설정을 제가 잘못했을지도 몰라서요.. 아래 올립니다..

xbroadcast 해도 서버가 안잡히길래 xbrowser에 억지로 서버를 추가하였습니다.


참고로 xbrowser에 잡힌 여러 서버들은 저희방이 아닌 다른 방에 있는 서버들로 OS가 솔라리스 입니다.

그리고 Fedora가 깔린 서버는 제 옆자리에 있는데도 안잡히네요...

랜선이 모자라 랜선 하나에 허브를 통하여 서버와 다른 PC가 같이 물려 있는데 혹시 그것 때문은 아닌지..

죄송하지만 한 번만 더 봐주세요..

혹시나 하고 묻는데요...

혹시 페도라6에는 이거 안잡히는거 아닙니까?

2007-10-25 17:12 - 넷사랑

Re: SELINUX disable 되어 있는데요..

 
FedoraCore6의 gdm이 이상한 동작을 하는 것 같습니다.
보내주신 그림 중 gdm-binary가 구동 중인 그림을 다시 보도록 하겠습니다.

첨부한 그림에서 노란 상자 A의 gdm-binary는 비정상적으로 구동되고 있는 데몬들입니다. init 명령으로 runlevel 상태를 바꿀 때 노란 상자 B와 같은 프로세스가 비정상적으로 살아남아 노란 상자 A와 같은 상태로 남게 됩니다.

문제는 이런 비정상적으로 구동되고 있는 gdm-binary가 있을 경우 제대로 XDM 제어를 해 주지 못하고 있는 것으로 나타났습니다. 아마도 이는 FedoraCore6의 버그로 보입니다.

최근의 리눅스의 경우 원격에서 하는 접속 제한을 더욱더 강화하는 경향이 있어 보입니다. FedoraCore6에서 Xmanager를 이용하여 XDMCP 접속을 하기 위한 방법을 다음과 같이 정리해 보도록 하겠습니다.

1. FAQ에 나와 있는 방법으로 gdm 설정을 마칩니다.

2. init 명령으로 runlevel을 바꾸기보다는 재부팅을 시도합니다.

3. iptables는 다음 명령으로 구동시키지 않도록 합니다.(문제의 원인을 단순화시키기 위한 방법입니다.)

#service iptables stop

4. selinux 서비스도 구동시키지 않도록 합니다.(사실 selinux의 기본 설정은 xdm 서비스와는 관련이 없습니다.)

5. ps 명령으로 gdm-binary 상태를 확인한 후 만약 위 그림과 같이 비정상적으로 구동 중인 데몬이 있다면 kill 명령으로 모든 gdm-binary를 종료시킨 후 수동으로 gdm을 구동시켜 봅니다.

6. 마지막으로 PC에 윈도우즈 방화벽 외에 은행사이트에서 제공하는 방화벽 프로그램이나 안티바이러스에서 같이 제공하는 방화벽 프로그램, 기타 방화벽 프로그램이 있는지 확인해 보시고 모두 종료하신 후 접속을 시도해 봅니다.


문제가 해결되기를 바랍니다.
감사합니다.
첨부파일 gdm.jpg (163.1 KB)  
2007-10-26 08:45 - 최소영

드디어 연결되었습니다... 그런데..

 
감사합니다. 위에 올려주신 대로 하니까 연결되고 정상적으로 로긴됩니다.

물론 리눅스 화면도 잘 보이구요...

모든 기능 원활히 사용할 수 있었습니다.

단 하나 안되는 것이 있는데..

root로 로긴하려고 하면 안되는 것입니다.

시스템 관리자가 이 화면에서 로긴을 허락하지 않았다는 메시지만 나오더군요...

사용자 설정 뭐.. 이런거 살펴봐도 root로 로긴할 수 있게 하려면 어떤 설정을 건드려야 하는지 알 수 없었습니다.

그래서 다시 한 번 질문합니다.

xbrowser에서 root로 로긴할 수 있으려면 어떻게 해주어야 하나요?

자꾸 귀찮게 해드려 죄송합니다..ㅋㅋ


2007-10-26 10:08 - 넷사랑

Re: 드디어 연결되었습니다... 그런데..

 
안녕하세요. 넷사랑컴퓨터 기술지원입니다.

문제가 해결되셨다니 다행입니다. 원격에서 root로 로그인이 되지 않는 문제는 /etc/gdm/custom.conf 파일의 [security] 섹션에 AllowRemoteRoot=true 를 추가한 후 gdm을 재구동하면 해결됩니다.

궁금한 사항이 생기면 언제든지 문의하시기 바랍니다.

감사합니다.

2007-10-26 10:43 - 최소영

시스템 재시작 하니 root로 연결되는군요 ㅠㅠ

 
감사합니다.

말씀하신대로 /etc/gdm/custom.conf의 [security]의 AllowRemoteRoot=true 해주고 시스템 재시작하니 root로 로긴됩니다...ㅠㅠ

위의 설정을 해주고 gdm restart 하니 root로긴 안되더라구요..
그래서 아예 재부팅하니까... ㅠㅠ 됐습니다...

감사합니다...
근 3일에 걸쳐 고생많으셨습니다...

좋은 시스템 잘쓰겠습니다.

그리고 오늘도 좋은 하루 보내십시요.