Xmanager 게시판

Ubuntu 7.10 또는 Kubuntu 7.10 에서 Xdmcp 설정법

최종입력: 2007-11-09 17:42 - ubuntu | 답글: 4건

 
2007-11-07 08:52 - ubuntu

Ubuntu 7.10 또는 Kubuntu 7.10 에서 Xdmcp 설정법

 
여기 FAQ에 나온대로 설정하면 Xbrowser가 작동하지 않습니다.

Ubuntu의 경우 /etc/gdm/gdm.conf 파일의
[Security]섹션
DisallowTCP=false
[XDMCP] 섹션
Enable=true
변경했을 경우 동작하지 않았고
/etc/X11/xinit/xserverrc 파일에서
-nolisten tcp 옵션도 제거해 줬는데도 로긴화면이 뜨지 않습니다.

nmap 으로 보면 리눅스 머신의 UDP 177번 포트(xdmcp) 열려있고 tcp 6000번 포트(x11) 열려 있는것으로 확인 됩니다.(Firewall은 작동 안시켰습니다.)

xmanager 로그를 보면 접속 시도하면 반응이 없어서 재접속 하는 것을 연속으로 수행하는데..접속은 되지 않습니다.

또한 Kubuntu 에서는 /etc/kde3/kdm 디렉터리 안에 설정파일들이 존재하는데 그것도 xdm.config은 찾을 수 없습니다. 역시 XDMCP 연결 안되구요.

연결할 수 있는 방법을 알려주세요.
2007-11-07 13:50 - 넷사랑

Re: Ubuntu 7.10 또는 Kubuntu 7.10 에서 Xdmcp 설정법

 
안녕하세요. 넷사랑컴퓨터 기술지원입니다.

리눅스 장비에 Xmanager로 접속하기 위한 기본적인 조건은 다음과 같습니다.

1. PC에서 리눅스 장비 쪽으로 UDP 177번 통신이 가능할 것
2. 리눅스 장비에서 PC 쪽으로 TCP 6000~6010번 통신이 가능할 것
3. 리눅스 장비에서 XDMCP 서비스가 활성화되고, 디스플레이 매니저가 구동되고 있을 것

먼저 PC와 리눅스 사이에 필요한 통신이 가능한지 점검해보십시오. 특히 리눅스 장비에서 PC 쪽으로 TCP 6000~6010번 통신이 PC에 사용자도 모르게 설치된 사설 방화벽 등에 의해 막힐 수도 있으니 확인해보시기 바랍니다.

Ubuntu (gdm 사용)의 경우 XDMCP 서비스 설정은 /etc/gdm/gdm.conf 파일에서 security 섹션에 DisallowTCP=false, XDMCP 섹션에 Enable=true로 설정한 후 gdm을 재구동하거나 혹은 init 3; init 5 명령을 내리면 됩니다. 환경 설정 파일을 수정한 후 gdm이 재구동 되어야 수정 사항이 반영됩니다.

Kubuntu (kdm 사용)의 경우 /etc/kde3/kdm/Xaccess 파일에서 다음 줄에 코멘트 기호(#)를 삭제합니다.
#* #any host can get a login window ==>
* #any host can get a login window
그리고 /etc/kde3/kdm/kdmrc 파일에서 XDMCP 섹션에 Enable=true로 설정한 후 kdm을 재구동하거나 혹은 init 3; init 5 명령을 내리면 됩니다.

참고로 /etc/X11/xinit/xserverrc 파일에서 -nolisten tcp 관련 옵션 설정은 콘솔의 X 서버에 적용되는 것이기 때문에 Xmanager 접속과는 관련이 없습니다.

위의 방법으로 문제가 해결되지 않으면 Xmanager 로그 파일을 보내주시면 문제의 원인을 파악하는데 도움이 될 것 같습니다.

감사합니다.
2007-11-07 18:05 - ubuntu

Re: Re: Ubuntu 7.10 또는 Kubuntu 7.10 에서 Xdmcp 설정법

 
일단 로그 파일을 보냅니다.

그리고 GNOME 설정파일은 /etc/gdm/gdm.conf-custom 파일이었습니다.

gdm.conf 파일 변경시켜보고 nmap으로 포트 살펴봤을때 변화 없었지만 gdm.conf-custom 파일 변경후 nmap으로 포트 살폈을 때 177번 UDP XDMCP 포트 열린 것 확인했구요. 6000번 TCP X11 포트 열린 것 확인했습니다.

nmap 확인시 177번 UDP와 6000번 TCP 포트가 열려있었는데도 로긴 창이 뜨지 않으니 답답합니다. ㅠ.ㅠ

네트웍 구조는 하나의 공유기 아래에 같은 클래스로 묶인 두 개의 시스템입니다. (WindowsXP, Ubuntu 7.10)

아..참 윈도우 시스템에 포트 막혔을까봐 여기 FAQ에 있는대로 Xmanager 외에도 6000번과 16001번 포트 예외로 두었습니다.

또한 Xstart로 ssh 접속은 잘 됩니다. 하지만 반드시 XDMCP로 접속해야 하는 이유가 있는지라...
첨부파일 X1.log (8.1 KB)  
2007-11-08 16:40 - 넷사랑

Re: Re: Re: Ubuntu 7.10 또는 Kubuntu 7.10 에서 Xdmcp 설정법

 
보내주신 로그를 분석해 보았습니다.

로그 중에 xdmcp Time out이 많이 발생하고 있습니다. 이는 네트워크가 불안정하여 패킷 손실이 많이 발생하는 상황이거나 XDM 데몬이 불안정할 경우에 주로 발생합니다.

XDM 데몬이 불안정한 경우는 데몬 자체의 문제도 있지만 PC와의 연결과정에서 Naming 서비스를 DNS 서버에 요청하는데 이 과정이 원활하지 못할 경우에 발생하기도 합니다. 이 경우에는 Xbrowser 리스트에도 늦게 뜨는 현상이 생기고 연결을 하더라도 늦게 되거나 아예 안되기도 합니다.

우선 /etc/hosts 파일에 PC의 IP 주소를 등록한 후 사용해 보십시오.

그래도 문제가 계속된다면 XDM 데몬으로 다른 데몬을 이용해 보시기 바랍니다.

kdm을 사용하고 있는 경우
#/etc/init.d/kdm stop
#/usr/sbin/gdm

gdm을 사용하고 있는 경우
#/etc/init.d/gdm stop
#/usr/sbin/kdm

xdm 데몬이 gdm, kdm 어느 것을 사용하더라도 사용자 환경은 KDE, GNOME 모두 사용하실 수 있습니다.

감사합니다.
2007-11-09 17:42 - ubuntu

Re: Re: Re: Re: Ubuntu 7.10 또는 Kubuntu 7.10 에서 Xdmcp 설정법

 
감사합니다. 문제를 해결했습니다.

kdm을 디스플레이매니저로 사용해야 접속이 가능하네요.

gdm은 아무리해도 ㅠ.ㅠ 접속 안됩니다.

그렇다면 kubuntu를 설치해도 안됐었는데....이럴 경우엔 gdm으로 디스플레이 매니저를 사용해야 하는걸까요? =_=

로그인매니저가 gdm이 편하던데... 어쨌든...어렵게 성공했네요 감사합니다.