Xshell 게시판

XSHELL5(0436) VI status line 글자표시 안됨 현상

최종입력: 2015-01-07 17:53 - 김지천 | 답글: 2건

 
2015-01-02 13:00 - 김지천

XSHELL5(0436) VI status line 글자표시 안됨 현상

 
환경 : windows7, XSHELL5(0436), Red Hat Enterprise Linux Server release 5.8

첨부1을 보시면 vi에서 search 했을 때 'pattern not found ' mesage 출력하는 경우 입니다.
보통은 빨간색 하이라이트박스로 mesage가 출력되나, 두 번째 이상 반복할 때는
아래쪽과 같이 일부만 표시되고 제대로 표시가 안됩니다.

첨부2의 경우는 VI의 search나 command mode에서 화살표키를 통해 command history를 볼 경우 입니다.
보시면 history가 제대로 표시가 안됩니다. 일부 글자만 나오고, 마우스 커서로 드래그하면 표시가 됩니다.
XSHELL3를 그동안 사용했는데 없었던 문제입니다. Xshell5를 설치하고 바로 나타난 문제이고,
PC 2대에서 따로따로 테스트 했을 때 같은 문제가 있었습니다.
글자체나 색조합을 변경했을때도 결과는 마찬가지였습니다.
확인 부탁드립니다.
감사합니다.

프로그램 버전 : Xshell 5
2015-01-02 18:29 - 넷사랑

Re: XSHELL5(0436) VI status line 글자표시 안됨 현상

 
안녕하십니까?
넷사랑컴퓨터 기술지원입니다.

보내 주신 정보를 보니 문제의 소지가 있는 것 같습니다.
이 문제는 사용하시는 vim의 환경과 관련이 있어 보입니다.
사용하시는 vim의 환경에 대한 정보를 보내 주시면 빠른 문제 해결에 도움이 될 것 같습니다.

1. .vimrc 파일 내용
2. screen 혹은 tmux 등의 가상 터미널 사용 여부
3. 기타 문제 해결에 도움이 될만한 정보(vim 하단의 상태바 정보 등)

감사합니다.
2015-01-07 17:53 - 김지천

Re: XSHELL5(0436) VI status line 글자표시 안됨 현상

 
Xshell 5 (build 0464)로 업데이트 하니 문제는 없어졌습니다.
요청하신 정보는 아래와 같습니다.

1. .vimrc 파일 내용
set ts=4
set title
set number
set autoindent
set smartindent
set cindent
set shiftwidth=4
set tabstop=4
set showmatch
set hlsearch
set ruler
set visualbell
set backspace=2
set ignorecase
colorscheme default

filetype on

set foldmethod=marker
set nobackup
syntax on
set title

map <F1> K
map <F2> :w!
map <F3> [{v]}zf
map <F4> zo
map <F5> :30vs.<CR>:set nonumber<CR>
map <F7> [i
"Ctag
map <F8> ^]
map <F9> ^T


2. screen 혹은 tmux 등의 가상 터미널 사용 여부
screen 사용함
3. 기타 문제 해결에 도움이 될만한 정보(vim 하단의 상태바 정보 등
해당사항 없음

감사합니다